BuiltInFailuresLinkFailures Class

Failures about LinkFailures.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresLinkFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class LinkFailures

The BuiltInFailuresLinkFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotModifyLinkedFile Shared Sites in the link ""%1!s!"" cannot be modified.
Public propertyStatic memberCannotOpenLinkedFileServerFound Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
Public propertyStatic memberCannotOpenLinkedFileServerNotFound Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
Public propertyStatic memberCannotPublishSharedCoordinatesToMirroredNonRevitLinks Shared coordinates cannot be published to mirrored, non Revit, links.
Public propertyStatic memberCannotReloadFile Can't reload file.
Public propertyStatic memberCannotUnlinkFile Can't unlink file.
Public propertyStatic memberDataDictionaryDifferentInLink Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
Public propertyStatic memberDeleteLinkSymbolPrompt All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
Public propertyStatic memberLinkedFileOpenInOtherDoc Linked file cannot be reloaded because it is loaded into another open document.
Public propertyStatic memberLinkInstanceNeedsReconcile Instance of linked .rvt file needs Coordination Review
Public propertyStatic memberModifiedLinkedFile Shared Sites in the link have been modified, use move instance to reset the change.
Public propertyStatic memberModifyingLinkedFile Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
Public propertyStatic memberMultipleLinks Can't complete operation. Linked Files have the same name.
Public propertyStatic memberNoConstraintsToLinks1 Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
Public propertyStatic memberSourceFileDrivenByOtherTarget Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
Public propertyStatic memberWatchedLinkMoved Monitored Link moved.
Top
See Also