RebarShapeConstraintProjectedSegmentLength Constructor |
Constructs a new instance of a RebarConstraintProjectEdgedLength object using a shape
parameter, direction, and reference types.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeConstraintProjectedSegmentLength(
ElementId paramId,
UV direction,
int tripleProductSign,
RebarShapeSegmentEndReferenceType refType0,
RebarShapeSegmentEndReferenceType refType1
)
Public Sub New (
paramId As ElementId,
direction As UV,
tripleProductSign As Integer,
refType0 As RebarShapeSegmentEndReferenceType,
refType1 As RebarShapeSegmentEndReferenceType
)
public:
RebarShapeConstraintProjectedSegmentLength(
ElementId^ paramId,
UV^ direction,
int tripleProductSign,
RebarShapeSegmentEndReferenceType refType0,
RebarShapeSegmentEndReferenceType refType1
)
new :
paramId : ElementId *
direction : UV *
tripleProductSign : int *
refType0 : RebarShapeSegmentEndReferenceType *
refType1 : RebarShapeSegmentEndReferenceType -> RebarShapeConstraintProjectedSegmentLength
Parameters
- paramId ElementId
-
The Id of a Rebar Shape parameter.
- direction UV
-
A vector specifying the direction of the constraint. The direction is fixed,
and the shape is always constructed so that the segment's
direction has a positive dot product with this vector.
- tripleProductSign Int32
-
Sign of the z-coordinate of the cross
product of the "direction" argument with the segment vector. In other words,
1 if the segment direction is to be on the left of the constraint direction,
or -1 if the segment direction is to be on the right.
- refType0 RebarShapeSegmentEndReferenceType
-
Choose between two possibilities for the first reference of the length constraint.
- refType1 RebarShapeSegmentEndReferenceType
-
Choose between two possibilities for the second reference of the length constraint.
Exceptions
See Also