PrimarySizeCriterion Class

This class contains a size criterion for a RoutingPreferenceRule.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRoutingCriterionBase
    Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrimarySizeCriterion : RoutingCriterionBase

The PrimarySizeCriterion type exposes the following members.

Constructors
 NameDescription
Public methodPrimarySizeCriterion Constructs a PrimarySizeCriterion with a minimum and maximum size.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RoutingCriterionBase)
Public propertyMaximumSize The maximum size of this criterion.
Public propertyMinimumSize The minimum size of this criterion.
Top
Methods
 NameDescription
Public methodStatic memberAll Creates a criterion with a range of all sizes.
Public methodDispose
(Inherited from RoutingCriterionBase)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsEqual Verify if two criteria are the same.
(Inherited from RoutingCriterionBase)
Public methodStatic memberNone Creates a criterion with a range of no sizes.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also