RoutingCriterionBase Class

RoutingCriteriaBase is the base class for all routing criteria.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRoutingCriterionBase
    Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoutingCriterionBase : IDisposable

The RoutingCriterionBase type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RoutingCriterionBase
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsEqual Verify if two criteria are the same.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also