TaskDialogShowingEventArgs Class

The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.UI.EventsDialogBoxShowingEventArgs
          Autodesk.Revit.UI.EventsTaskDialogShowingEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs

The TaskDialogShowingEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyDialogId A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.
(Inherited from DialogBoxShowingEventArgs)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyMessage The message that has been displayed in the dialog box.
Top
Methods
 NameDescription
Public methodCancel When the event is cancellable, may call the Cancel() method to cancel it.
(Inherited from RevitAPIPreEventArgs)
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodOverrideResult Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
(Inherited from DialogBoxShowingEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
See Also