DialogBoxShowingEventArgsDialogId Property |
A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string DialogId { get; }
Public ReadOnly Property DialogId As String
Get
public:
property String^ DialogId {
String^ get ();
}
member DialogId : string with get
Property Value
String
Remarks
The contents of this entry vary depending on the type of dialog which is shown:
- DialogBox: A unique string ID that can be used to identify those whihch dialog has been invoked.
- TaskDialog: The customed string if TaskDialog.Id is set, empty string for default TaskDialog.Show(). For Revit-created dialog boxes, this
should always have an assigned value.
- Standard Message Boxes: this will be an empty string.
See Also