Family |
The FamilyStructuralMaterialTypeFilter type exposes the following members.
Name | Description | |
---|---|---|
![]() | FamilyStructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match families that have the given structural material type. |
![]() | FamilyStructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type. |
Name | Description | |
---|---|---|
![]() | StructuralMaterialType | The family structural material type. |
Name | Description | |
---|---|---|
// Use FamilyStructuralMaterialType filter to find families whose material type is Wood FamilyStructuralMaterialTypeFilter filter = new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood); // Apply the filter to the elements in the active document FilteredElementCollector collector = new FilteredElementCollector(document); ICollection<Element> woodFamiles = collector.WherePasses(filter).ToElements(); // Find families are not Wood: Use inverted filter to match families FamilyStructuralMaterialTypeFilter notWoodFilter = new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood, true); // inverted filter collector = new FilteredElementCollector(document); ICollection<Element> notWoodFamilies = collector.WherePasses(notWoodFilter).ToElements();