FamilyStructuralMaterialTypeFilter(StructuralMaterialType, Boolean) Constructor |
Constructs a new instance of a filter to match families by structural material type,
with the option to match all families which are not of the given structural material type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyStructuralMaterialTypeFilter(
StructuralMaterialType structuralMaterialType,
bool inverted
)
Public Sub New (
structuralMaterialType As StructuralMaterialType,
inverted As Boolean
)
public:
FamilyStructuralMaterialTypeFilter(
StructuralMaterialType structuralMaterialType,
bool inverted
)
new :
structuralMaterialType : StructuralMaterialType *
inverted : bool -> FamilyStructuralMaterialTypeFilter
Parameters
- structuralMaterialType StructuralMaterialType
-
The structural material type to match.
- inverted Boolean
-
True if the filter should match all families which are not of the given structural material type.
Exceptions
See Also