RebarShapeDefinitionByArcAddConstraintCircumference Method |
Specify a parameter to drive the circumference of the shape.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddConstraintCircumference(
ElementId paramId,
RebarShapeArcReferenceType arcRefType
)
Public Sub AddConstraintCircumference (
paramId As ElementId,
arcRefType As RebarShapeArcReferenceType
)
public:
void AddConstraintCircumference(
ElementId^ paramId,
RebarShapeArcReferenceType arcRefType
)
member AddConstraintCircumference :
paramId : ElementId *
arcRefType : RebarShapeArcReferenceType -> unit
Parameters
- paramId ElementId
-
Id of a parameter to drive the constraint.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
- arcRefType RebarShapeArcReferenceType
-
Specify along which circle the circumference is measured--to the interior
of the bar, the centerline, or the exterior.
Exceptions
See Also