ExternalResourceType Class

A type class used to distinguish between different kinds of external resource.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGuidEnum
    Autodesk.Revit.DBExternalResourceType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceType : GuidEnum

The ExternalResourceType type exposes the following members.

Constructors
 NameDescription
Public methodExternalResourceTypeCreates a new ExternalResourceType instance.
Top
Properties
 NameDescription
Public propertyGuid The Guid of GUID-based enum object.
(Inherited from GuidEnum)
Top
Methods
 NameDescription
Public methodEquals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum)
Public methodGetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Operators
 NameDescription
Public operatorStatic memberEquality(ExternalResourceType, ExternalResourceType)Compares two ExternalResourceType instances.
Public operatorStatic memberInequality(ExternalResourceType, ExternalResourceType)Compares two ExternalResourceType instances.
Top
Remarks
Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.
See Also