IFCCategoryTemplateGetMappingInfoById Method |
Gets a copy of ifc mapping info by category id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExportIFCCategoryInfo GetMappingInfoById(
Document document,
ElementId categoryId,
CustomSubCategoryId customSubCategoryId
)
Public Function GetMappingInfoById (
document As Document,
categoryId As ElementId,
customSubCategoryId As CustomSubCategoryId
) As ExportIFCCategoryInfo
public:
ExportIFCCategoryInfo^ GetMappingInfoById(
Document^ document,
ElementId^ categoryId,
CustomSubCategoryId customSubCategoryId
)
member GetMappingInfoById :
document : Document *
categoryId : ElementId *
customSubCategoryId : CustomSubCategoryId -> ExportIFCCategoryInfo
Parameters
- document Document
-
A Revit document.
- categoryId ElementId
-
The category id.
- customSubCategoryId CustomSubCategoryId
-
The custom subcategory id.
Return Value
ExportIFCCategoryInfo
Return the info for this category.
Exceptions
See Also