CustomSubCategoryId Enumeration |
An enumerated type listing pseudo sub-categories that can appear in a mapping template.
These types do not represent an independent category in Revit, but can be mapped to specific IFC
entity.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum CustomSubCategoryId
Public Enumeration CustomSubCategoryId
public enum class CustomSubCategoryId
MembersMember name | Value | Description |
---|
InteriorWall | 1 |
The custom id representing interior walls.
|
ExteriorWall | 2 |
The custom id representing exterior walls.
|
FoundationWall | 3 |
The custom id representing foundation walls.
|
RetainingWall | 4 |
The custom id representing retaining walls.
|
Coreshaft | 5 |
The custom id representing cores/shafts.
|
Soffit | 6 |
The custom id representing soffits.
|
None | -1 |
The default value for most Revit categories and subcategories.
|
See Also