GroundConductorSize Class

Represents electrical ground conductor size definition information.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.ElectricalGroundConductorSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GroundConductorSize : APIObject

The GroundConductorSize type exposes the following members.

Properties
 NameDescription
Public propertyAmpacity Get ampacity which is used for specifying size, the unit is ampere.
Public propertyConductorSize Get conductor size corresponding to specific ampacity.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyMaterialBelongTo Get the material type which include this ground conductor size information.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Ground conductor size is defined based on corresponding wire material type.
See Also