DoubleClickOptions Class

Provides access to settings that control what happens when the current user double-clicks on an element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIDoubleClickOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DoubleClickOptions : IDisposable

The DoubleClickOptions type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DoubleClickOptions
Public methodGetAction Returns the active user's desired action for a particular double-click target.
Public methodStatic memberGetDoubleClickOptions Returns the current user's DoubleClickOptions.
Public methodGetRenameOnSlowDoubleClickInProjectBrowser Returns the user's desire to rename item in project browser on slow double-click.
Public methodIsSupportedAction Checks whether the specified double-click target supports the specified action.
Public methodSetAction Changes the double-click action associated with a specified target.
Public methodSetRenameOnSlowDoubleClickInProjectBrowser Sets whether the desired action is to rename item in project browser on slow double-click.
Top
Remarks
These settings are stored on a per-user basis. Revit will follow these settings for all projects and families for this user.
See Also