BuiltInFailuresSiteImportFailures Class

Failures about SiteImport.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresSiteImportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SiteImportFailures

The BuiltInFailuresSiteImportFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberBoundaryDetectError A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
Public propertyStatic memberContoursNoncontours The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
Public propertyStatic memberDifferentEntityTypes Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
Public propertyStatic memberInvalidBoundaryError Failed to get a valid boundary.
Public propertyStatic memberNoPoints No points were found in the file.
Public propertyStatic memberNoViewSpecificSiteImports Can't make Toposurface from View Specific Imports.
Public propertyStatic memberSurfaceExists You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
Public propertyStatic memberTooFarAway Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
Public propertyStatic memberTooFewPoints The toposolid must have at least three distinct points
Public propertyStatic memberTooLarge There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid
Public propertyStatic memberTooManyMeshes The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
Public propertyStatic memberUnusedPoints Some rows from the file could not be used.
Top
See Also