ViewPrintingEventArgs Class

The event arguments used by the ViewPrinting event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewPrintingEventArgs : RevitAPIPreDocEventArgs

The ViewPrintingEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyIndex The index of the view being printed out of the set of all views being printed.
Public propertyTotalViews The number of all views being printed.
Public propertyView The view to be printed.
Top
Methods
 NameDescription
Public methodGetSettings Get the print settings of the active printing session.
Top
See Also