CompoundStructureSplitRegion(UV, RectangularGridSegmentOrientation) Method

Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int SplitRegion(
	UV gridUV,
	RectangularGridSegmentOrientation splitDirection
)

Parameters

gridUV  UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection  RectangularGridSegmentOrientation
Specifies the direction of the split.

Return Value

Int32
The id of the region created by this operation.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Split and merge regions operations can be used only for vertically compound structures without variable thickness layers.
Remarks
This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32, Int32). Grid coordinates correspond to uv coordinates of faces.
See Also