CompoundStructureFindEnclosingRegionAndSegments Method |
Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments
intersected by a line through the grid point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int FindEnclosingRegionAndSegments(
UV gridUV,
RectangularGridSegmentOrientation splitDirection,
out int segmentId1,
out int segmentId2
)
Public Function FindEnclosingRegionAndSegments (
gridUV As UV,
splitDirection As RectangularGridSegmentOrientation,
<OutAttribute> ByRef segmentId1 As Integer,
<OutAttribute> ByRef segmentId2 As Integer
) As Integer
public:
int FindEnclosingRegionAndSegments(
UV^ gridUV,
RectangularGridSegmentOrientation splitDirection,
[OutAttribute] int% segmentId1,
[OutAttribute] int% segmentId2
)
member FindEnclosingRegionAndSegments :
gridUV : UV *
splitDirection : RectangularGridSegmentOrientation *
segmentId1 : int byref *
segmentId2 : int byref -> int
Parameters
- gridUV UV
-
Coordinates of a point in the rectangular grid of this compound structure.
- splitDirection RectangularGridSegmentOrientation
-
Specifies the direction of the split.
- segmentId1 Int32
-
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
- segmentId2 Int32
-
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
Return Value
Int32
Returns the id of the enclosing region, and -1 if no region encloses the point.
Exceptions
Remarks
Grid coordinates correspond to uv coordinates of faces.
See Also