ExporterIFCUtilsIsWallCompletelyClipped Method |
Determines if the input wall is completely removed by interaction with other elements
within the given range.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsWallCompletelyClipped(
Wall pVWall,
ExporterIFC exporterIFC,
IFCRange range
)
Public Shared Function IsWallCompletelyClipped (
pVWall As Wall,
exporterIFC As ExporterIFC,
range As IFCRange
) As Boolean
public:
static bool IsWallCompletelyClipped(
Wall^ pVWall,
ExporterIFC^ exporterIFC,
IFCRange^ range
)
static member IsWallCompletelyClipped :
pVWall : Wall *
exporterIFC : ExporterIFC *
range : IFCRange -> bool
Parameters
- pVWall Wall
-
The wall.
- exporterIFC ExporterIFC
-
The exporter.
- range IFCRange
-
The range. This consists of two double values representing the height in Z at the start and the end
of the range. If the values are identical the entire wall is used.
Return Value
Boolean
True if the wall should be ignored within the given range.
Exceptions
See Also