CommandMenuItem Class

A class representing a single command menu item.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIMenuItem
    Autodesk.Revit.UICommandMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CommandMenuItem : MenuItem

The CommandMenuItem type exposes the following members.

Constructors
 NameDescription
Public methodCommandMenuItem Initialize the item data.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Public methodSetAvailabilityClassName Set availabilityClassName of CommandMenuItem
Public methodSetToolTip Set toolTip of CommandMenuItem
Top
Remarks

To add a menu item that can be executed, implement IExternalCommand interface and pass external command class name to CommandMenuItem constructor, create the CommandMenuItem object and use AddItem() method to add the object to context menu.

See Also