CommandMenuItem Constructor |
Initialize the item data.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CommandMenuItem(
string name,
string className,
string assemblyName
)
Public Sub New (
name As String,
className As String,
assemblyName As String
)
public:
CommandMenuItem(
String^ name,
String^ className,
String^ assemblyName
)
new :
name : string *
className : string *
assemblyName : string -> CommandMenuItem
Parameters
- name String
-
The name will show on menu.
- className String
-
The class name which implements IExternalCommand interface.
- assemblyName String
-
The path of the assembly which contains the corresponding external command.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
className is an empty string or contains only whitespace.
-or-
assemblyName is an empty string or contains only whitespace.
|
ArgumentNullException |
A non-optional argument was null
|
See Also