ClassificationEntries Class

A collection of ClassificationEntry objects that make up the classification table.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBKeyBasedTreeEntries
    Autodesk.Revit.DBClassificationEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ClassificationEntries : KeyBasedTreeEntries

The ClassificationEntries type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from KeyBasedTreeEntries)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from KeyBasedTreeEntries)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodFindEntry Finds the KeyBasedTreeEntry associated with the given key value.
(Inherited from KeyBasedTreeEntries)
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
(Inherited from KeyBasedTreeEntries)
Public methodGetEnumeratorReturns an enumerator that iterates through a collection.
(Inherited from KeyBasedTreeEntries)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetKeyBasedTreeEntriesIterator Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
(Inherited from KeyBasedTreeEntries)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberLoadClassificationEntriesFromFile Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also