KeyBasedTreeEntries Class

A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBKeyBasedTreeEntries
    Autodesk.Revit.DBClassificationEntries
    Autodesk.Revit.DBKeynoteEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry>, 
	IDisposable

The KeyBasedTreeEntries type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the KeyBasedTreeEntries
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodFindEntry Finds the KeyBasedTreeEntry associated with the given key value.
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetKeyBasedTreeEntriesIterator Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also