RibbonPanelAddItem Method |
Adds a Ribbon item to the panel.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RibbonItem AddItem(
RibbonItemData itemData
)
Public Function AddItem (
itemData As RibbonItemData
) As RibbonItem
public:
RibbonItem^ AddItem(
RibbonItemData^ itemData
)
member AddItem :
itemData : RibbonItemData -> RibbonItem
Parameters
- itemData RibbonItemData
- Data containing information about the new item.
Return Value
RibbonItem The added Ribbon item.
ExceptionsException | Condition |
---|
ArgumentNullException | Thrown when itemData is . |
ArgumentException | Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type. |
Remarks The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in.
The new item may be created as a large-size vertical control in the panel.
See Also