ConnectionValidationWarning Constructor |
Constructor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ConnectionValidationWarning(
ConnectionResolution resolution,
ConnectionWarning reason,
ElementId part1,
ElementId part2
)
Public Sub New (
resolution As ConnectionResolution,
reason As ConnectionWarning,
part1 As ElementId,
part2 As ElementId
)
public:
ConnectionValidationWarning(
ConnectionResolution resolution,
ConnectionWarning reason,
ElementId^ part1,
ElementId^ part2
)
new :
resolution : ConnectionResolution *
reason : ConnectionWarning *
part1 : ElementId *
part2 : ElementId -> ConnectionValidationWarning
Parameters
- resolution ConnectionResolution
-
Resolution type.
- reason ConnectionWarning
-
Warning reason.
- part1 ElementId
-
First element Id.
- part2 ElementId
-
Second element Id.
Exceptions
See Also