ConnectionWarning Enumeration |
An enumerated type listing all the reasons for connectivity failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ConnectionWarning
Public Enumeration ConnectionWarning
public enum class ConnectionWarning
MembersMember name | Value | Description |
---|
Unknown | 0 |
Value for unknown or unspecified reason.
|
Alignment | 1 |
Value for parts were moved when rebuilt so that connectors were no longer aligned.
|
Size | 2 |
Value for sizes didn't match.
|
Shape | 3 |
Value for shapes didn't match.
|
Connectivity | 4 |
Value for fabrication Connectivity Mismatch.
|
See Also