PointOnFace Class

Define a ReferencePoint relative to a Face.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointElementReference
    Autodesk.Revit.DBPointOnFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnFace : PointElementReference

The PointOnFace type exposes the following members.

Properties
 NameDescription
Public propertyUVThe location of the point in the surface's coordinate system.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetFaceReferenceGet a copy of the face reference.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetFaceReferenceChange the face reference.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).
See Also