DocumentNewOpening(Level, Level, CurveArray) Method |
Creates a new shaft opening between a set of levels.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Opening NewOpening(
Level bottomLevel,
Level topLevel,
CurveArray profile
)
Public Function NewOpening (
bottomLevel As Level,
topLevel As Level,
profile As CurveArray
) As Opening
public:
Opening^ NewOpening(
Level^ bottomLevel,
Level^ topLevel,
CurveArray^ profile
)
member NewOpening :
bottomLevel : Level *
topLevel : Level *
profile : CurveArray -> Opening
Parameters
- bottomLevel Level
- bottom level
- topLevel Level
- top level
- profile CurveArray
- profile of the opening.
Return Value
Opening If successful, an Opening object is returned.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the bottom level does not exist in the given document. |
ArgumentException | Thrown if the top level does not exist in the given document. |
Remarks This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.
See Also