SpatialElementGeometryResultsGetBoundaryFaceInfo Method |
Query the spatial element boundary face information with the given face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
Face face
)
Public Function GetBoundaryFaceInfo (
face As Face
) As IList(Of SpatialElementBoundarySubface)
public:
IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo(
Face^ face
)
member GetBoundaryFaceInfo :
face : Face -> IList<SpatialElementBoundarySubface>
Parameters
- face Face
-
The face from the spatial element's geometry.
Return Value
IListSpatialElementBoundarySubface
Sub-faces related to the room bounding elements that define the spatial element face. Returns
if there is no corresponding boundary information with the given face.
Exceptions
See Also