ExporterIFCPushExportState Method |
Sets the internal state of the exporter to process the geometry and properties of the input element.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void PushExportState(
Element Elem,
GeometryElement GRep
)
Public Sub PushExportState (
Elem As Element,
GRep As GeometryElement
)
public:
void PushExportState(
Element^ Elem,
GeometryElement^ GRep
)
member PushExportState :
Elem : Element *
GRep : GeometryElement -> unit
Parameters
- Elem Element
-
The element.
- GRep GeometryElement
-
The geometry of the element. Optional, can be .
Exceptions
Remarks
The element will be assigned until PopExportState() is called.
See Also