DWFImportOptions Class

The import options used by importing DWF or DWFx format file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDWFImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DWFImportOptions : IDisposable

The DWFImportOptions type exposes the following members.

Constructors
 NameDescription
Public methodDWFImportOptions(DWFImportOptions) Constructs a new instance of DWFImportOptions as a copy of the import options.
Public methodDWFImportOptions(IListElementId) Constructs a new instance of DWFImportOptions with an array of imported sheet views.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DWFImportOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetSheetViews Get sheet views where DWF markups are imported.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetSheetViews Set sheet views where DWF markups are imported.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also