ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean) Constructor

Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ICollection<ElementOnPhaseStatus> phaseStatuses,
	bool inverted
)

Parameters

phaseId  ElementId
Id of the phase.
phaseStatuses  ICollectionElementOnPhaseStatus
Target statuses.
inverted  Boolean
True to match all phase statuses other than the input statuses.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also