ElementOnPhaseStatus Enumeration |
The statuses that an element can have with respect to a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ElementOnPhaseStatus
Public Enumeration ElementOnPhaseStatus
public enum class ElementOnPhaseStatus
type ElementOnPhaseStatus
MembersMember name | Value | Description |
---|
None | 0 |
Phase status is undefined (e.g., for annotations)
|
Past | 1 |
Created and demolished before the given phase
|
Existing | 2 |
Created in a previous phase, existing through the end of the given phase
|
Demolished | 3 |
Created before the given phase, to be demolished on the given phase
|
New | 4 |
Created on this phase (and not demolished)
|
Temporary | 5 |
Created and demolished during this phase
|
Future | 6 |
Created after this phase
|
See Also