NonContinuousRailInfoIsValidNonContinuousRailProfile Method

Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidNonContinuousRailProfile(
	ElementId profileId
)

Parameters

profileId  ElementId
The profile Id to be checked.

Return Value

Boolean
True if the ElementId refers to a valid NonContinuousRail profile, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
InvalidElementId is considered a valid NonContinuousRail profile (the default profile).
See Also