AssetSetIterator Class

Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.VisualAssetSetIterator

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class AssetSetIterator : APIObject, 
	IEnumerator

The AssetSetIterator type exposes the following members.

Constructors
 NameDescription
Public methodAssetSetIteratorInitializes a new instance of the AssetSetIterator class
Top
Properties
 NameDescription
Public propertyCurrent 
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodMoveNext 
Public methodReset 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also