FabricationPartRouteEndCreateFromCenterline Method |
Create fabrication routing end from centerline point on straight element.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FabricationPartRouteEnd CreateFromCenterline(
Element element,
XYZ ptAt
)
Public Shared Function CreateFromCenterline (
element As Element,
ptAt As XYZ
) As FabricationPartRouteEnd
public:
static FabricationPartRouteEnd^ CreateFromCenterline(
Element^ element,
XYZ^ ptAt
)
static member CreateFromCenterline :
element : Element *
ptAt : XYZ -> FabricationPartRouteEnd
Parameters
- element Element
-
The straight element that the centerline is on.
- ptAt XYZ
-
A point along the straight element where the fitting to be cut in should be positioned.
Return Value
FabricationPartRouteEnd
Exceptions
See Also