FabricationPartRouteEnd Class

Class to hold fabrication part routing start or end information.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.FabricationFabricationPartRouteEnd

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationPartRouteEnd : IDisposable

The FabricationPartRouteEnd type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberCreateFromCenterline Create fabrication routing end from centerline point on straight element.
Public methodStatic memberCreateFromConnector Create fabrication routing end from connector end point.
Public methodDisposeReleases all resources used by the FabricationPartRouteEnd
Top
Remarks
To create a new instance, use CreateFromConnector(Connector) to specify a connector, or CreateFromCenterline(Element, XYZ) to specify the centerline of a straight element, for the fabrication routing end point.
See Also