gbXMLBuildingType Enumeration |
Enumerations for gbXML (Green Building XML) format, used for energy
analysis, schema version 0.34.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum gbXMLBuildingType
Public Enumeration gbXMLBuildingType
public enum class gbXMLBuildingType
MembersMember name | Value | Description |
---|
AutomotiveFacility | 0 | |
ConventionCenter | 1 | |
Courthouse | 2 | |
DiningBarLoungeOrLeisure | 3 | |
DiningCafeteriaFastFood | 4 | |
DiningFamily | 5 | |
Dormitory | 6 | |
ExerciseCenter | 7 | |
FireStation | 8 | |
Gymnasium | 9 | |
NoBuildingType | -1 | |
HospitalOrHealthcare | 10 | |
Hotel | 11 | |
Library | 12 | |
Manufacturing | 13 | |
Motel | 14 | |
MotionPictureTheatre | 15 | |
MultiFamily | 16 | |
Museum | 17 | |
Office | 18 | |
ParkingGarage | 19 | |
CustomizeBuildingType | -2 | |
Penitentiary | 20 | |
PerformingArtsTheater | 21 | |
PoliceStation | 22 | |
PostOffice | 23 | |
ReligiousBuilding | 24 | |
Retail | 25 | |
SchoolOrUniversity | 26 | |
SingleFamily | 27 | |
SportsArena | 28 | |
TownHall | 29 | |
Transportation | 30 | |
Warehouse | 31 | |
Workshop | 32 | |
NoOfBuildingTypes | 33 | |
See Also