ExporterIFCUtilsGetIFCClassNameByCategory Method |
Note: This API is now obsolete.
Obtains the IFC class name associated to a given category id for the current export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")]
public static string GetIFCClassNameByCategory(
ElementId catId,
ExporterIFC exporterIFC
)
<ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")>
Public Shared Function GetIFCClassNameByCategory (
catId As ElementId,
exporterIFC As ExporterIFC
) As String
public:
[ObsoleteAttribute(L"This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")]
static String^ GetIFCClassNameByCategory(
ElementId^ catId,
ExporterIFC^ exporterIFC
)
[<ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")>]
static member GetIFCClassNameByCategory :
catId : ElementId *
exporterIFC : ExporterIFC -> string
Parameters
- catId ElementId
-
The category id.
- exporterIFC ExporterIFC
-
The exporter.
Return Value
String
The IFC class name. This is an empty string if the element should not be exported because it is not
found in the mapping file.
Exceptions
Remarks
IFC class names are affected by the user's entries in the mapping file set for a
given export operation.
See Also