StructuralSectionUtilsGetStructuralSection Method |
Return structural section from element.
Namespace: Autodesk.Revit.DB.Structure.StructuralSectionsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static StructuralSection GetStructuralSection(
Document document,
ElementId elementId
)
Public Shared Function GetStructuralSection (
document As Document,
elementId As ElementId
) As StructuralSection
public:
static StructuralSection^ GetStructuralSection(
Document^ document,
ElementId^ elementId
)
static member GetStructuralSection :
document : Document *
elementId : ElementId -> StructuralSection
Parameters
- document Document
-
The document that owns the family for beam, brace or structural column.
- elementId ElementId
-
ID of family symbol or family instance for beam, brace or structural column.
Return Value
StructuralSection
Structural section returned if element have one.
For elements that do not have structural section or can not have structural section
will be returned.
Exceptions
Remarks
Only beams, braces and structural columns can have structural section associated with it.
See Also