RailingRailingCanBeHostedByElement Method |
Checks whether the specified element can be used as a host for the railing.
The host can be:
- stairs
- stairs component
- ramp
- floor
- slab edge
- wall
- roof
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool RailingCanBeHostedByElement(
ElementId hostId
)
Public Function RailingCanBeHostedByElement (
hostId As ElementId
) As Boolean
public:
bool RailingCanBeHostedByElement(
ElementId^ hostId
)
member RailingCanBeHostedByElement :
hostId : ElementId -> bool
Parameters
- hostId ElementId
-
Element id to check.
Return Value
Boolean
True if the element can be used as host for the railing.
Exceptions
See Also