CompoundStructureSplitRegion(UV, RectangularGridSegmentOrientation, Int32) Method |
Splits the region which contains the specified grid point by a line with the specified direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int SplitRegion(
UV gridUV,
RectangularGridSegmentOrientation splitDirection,
out int newSegmentId
)
Public Function SplitRegion (
gridUV As UV,
splitDirection As RectangularGridSegmentOrientation,
<OutAttribute> ByRef newSegmentId As Integer
) As Integer
public:
int SplitRegion(
UV^ gridUV,
RectangularGridSegmentOrientation splitDirection,
[OutAttribute] int% newSegmentId
)
member SplitRegion :
gridUV : UV *
splitDirection : RectangularGridSegmentOrientation *
newSegmentId : int byref -> int
Parameters
- gridUV UV
-
Coordinates of a point in the rectangular grid of this compound structure.
- splitDirection RectangularGridSegmentOrientation
-
Specifies the direction of the split.
- newSegmentId Int32
-
The id of segment that bounds both the original region and the new region.
Return Value
Int32
The id of the region created by this operation.
Exceptions
Remarks
See Also