ContinuousRailTypeProfileId Property |
The id of the profile of the rail
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId ProfileId { get; set; }
Public Property ProfileId As ElementId
Get
Set
public:
property ElementId^ ProfileId {
ElementId^ get ();
void set (ElementId^ value);
}
member ProfileId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The profileId is neither a valid element id nor invalidElementId.
-or-
When setting this property: The profileId is not a valid profile symbol for continuous rail.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also