AssemblyViewUtilsCreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) Method

Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewSection CreateDetailSection(
	Document document,
	ElementId assemblyInstanceId,
	AssemblyDetailViewOrientation direction
)

Parameters

document  Document
The document to which the view will be added.
assemblyInstanceId  ElementId
Id of the assembly instance that owns the new view.
direction  AssemblyDetailViewOrientation
The direction for the new view.

Return Value

ViewSection
A new detail section assembly view.
Exceptions
ExceptionCondition
ArgumentException assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.
See Also