AssemblyDetailViewOrientation Enumeration |
Orientation of the Assembly Detail View.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AssemblyDetailViewOrientation
Public Enumeration AssemblyDetailViewOrientation
public enum class AssemblyDetailViewOrientation
type AssemblyDetailViewOrientation
MembersMember name | Value | Description |
---|
HorizontalDetail | 0 |
The Detail View will be oriented horizontally, looking down.
|
DetailSectionA | 1 |
The Detail View will be oriented vertically, looking north.
|
DetailSectionB | 2 |
The Detail View will be oriented vertically, looking west.
|
ElevationTop | 3 |
The Detail View will be oriented horizontally, with its cut plane along the top face of the assembly's bounding box, looking down into the bounding box.
|
ElevationBottom | 4 |
The Detail View will be oriented horizontally, with its cut plane along the bottom face of the assembly's bounding box, looking up into the bounding box.
|
ElevationLeft | 5 |
The Detail View will be oriented vertically, with its cut plane along the left face of the assembly's bounding box, looking into the bounding box.
|
ElevationRight | 6 |
The Detail View will be oriented vertically, with its cut plane along the right face of the assembly's bounding box, looking into the bounding box.
|
ElevationFront | 7 |
The Detail View will be oriented vertically, with its cut plane along the front face of the assembly's bounding box, looking into the bounding box.
|
ElevationBack | 8 |
The Detail View will be oriented vertically, with its cut plane along the back face of the assembly's bounding box, looking into the bounding box.
|
Remarks
The orientation can be specified during creation but not modified for existing views.
See Also