ExportLineweightInfo Class

A value used to represent the info stored in the ExportLineweightTable.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExportLineweightInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLineweightInfo : IDisposable

The ExportLineweightInfo type exposes the following members.

Constructors
 NameDescription
Public methodExportLineweightInfo Constructs a new default ExportLineweightInfo.
Public methodExportLineweightInfo(ExportLineweightInfo) Constructs a new copy of the input ExportLineweightInfo object.
Public methodExportLineweightInfo(String) Constructs a new ExportLineweightInfo using the destination line weight name as input.
Top
Properties
 NameDescription
Public propertyDestinationLineweightName The destination lineweight name (the name of the line weight in the exported format)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExportLineweightInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also