StairsTypeRightSideSupportType Property |
The type of right support used in the stair.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId RightSideSupportType { get; set; }
Public Property RightSideSupportType As ElementId
Get
Set
public:
property ElementId^ RightSideSupportType {
ElementId^ get ();
void set (ElementId^ value);
}
member RightSideSupportType : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: rightSideStringerTypeId is not a valid support type.
-or-
When setting this property: The specified rightSideStringerTypeId doesn't match the desired style of the right side support.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
When setting this property: The right support style is none, so this related data cannot be set.
|
See Also