ExportUtils Class

This class provides utilities related to document export.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExportUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExportUtils

The ExportUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberGetExportId(Subelement) Retrieves the GUID representing the subelement in DWF and IFC export.
Public methodStatic memberGetExportId(Document, ElementId) Retrieves the GUID representing this element in DWF and IFC export.
Public methodStatic memberGetGBXMLDocumentId Retrieves the GUID representing this document in exported gbXML files.
Public methodStatic memberGetNurbsSurfaceDataForSurface Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].
Top
See Also