ExportUtilsGetGBXMLDocumentId Method

Retrieves the GUID representing this document in exported gbXML files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Guid GetGBXMLDocumentId(
	Document document
)

Parameters

document  Document
The document.

Return Value

Guid
The value of the GUID representing this document in gbXML export.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
This id can be used to cross-reference different gbXML exports from the same document.
See Also