ExportUtilsGetExportId(Subelement) Method |
Retrieves the GUID representing the subelement in DWF and IFC export.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Guid GetExportId(
Subelement subelement
)
Public Shared Function GetExportId (
subelement As Subelement
) As Guid
public:
static Guid GetExportId(
Subelement^ subelement
)
static member GetExportId :
subelement : Subelement -> Guid
Parameters
- subelement Subelement
-
The subelement.
Return Value
Guid
The value of the GUID representing the subelement in the export context.
Exceptions
Remarks
This id is used in the contents of DWF export and IFC export and it should be used
only when cross-referencing to the contents of these export formats.
When storing Ids that will need to be mapped back to subelements in future sessions,
UniqueId must be used.
See Also